Invoice, Purchase Order and Emburse Analytics Inaccessible

Incident

Invoice, Purchase Order and Emburse Analytics Inaccessible

Status: closed
Start:
End:
Duration: 40 minutes
Affected Components:
C5 Instance INVOICE - C5 Instance General Invoice
Update

Emburse Enterprise is aware of issues accessing the Invoice and Purchase Order aspects of the application. Our Operations team is taking a look as their top priority and will provide an update shortly.

Update

We have also identified that Emburse Analytics is unable to be accessed at this time. Our Operations team is continuing to review and we will provide an update shortly.

Resolved

Our Operations team has resolved an issue causing Invoice, Purchase Order and Emburse Analytics to be inaccessible. We apologize for any inconvenience this may have caused.