Performance Degradation

Incident

Performance Degradation

Status: closed
Start:
End:
Duration: 37 minutes
Affected Components:
C3 Instance General Application Status - C3 Instance Login Feeds Emails API
Investigating

We are currently experiencing degraded performance and some users may notice slowness, delayed responses or partial outages.

Our engineering team is actively investigating the root cause and working to restore full performance.

We will provide an updates as soon as more information becomes available.

We appreciate your patience and understanding.


Resolved

Our engineering team has successfully resolved the performance degradation issues some users experienced today.


We appreciate your patience and understanding as we worked to address and resolve this matter.