Application Slowness and Issues Logging In

Incident

Application Slowness and Issues Logging In

Status: closed
Start:
End:
Duration: 1 hour 12 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance INVOICE - C5 Instance Login General Invoice Emails Image Processing Exports Purchase Order
Update

We're aware that some users are experiencing issues with logging in, as well as general slowness when navigating the application specifically the invoice module.

Our operations team is actively investigating the issue and treating it as a top priority. We’ll share updates as soon as we have more information.

Resolved

Our operations team has resolved the issues with logging in, as well as general slowness when navigating the application. 

We apologize for any inconvience this has caused.