Site slowness

Incident

Site slowness

Status: closed
Start:
End:
Duration: 34 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance Login Feeds Emails API
Update

We're aware that some users are experiencing issues with logging in, as well as general slowness when navigating the application and uploading images.

Our operations team is actively investigating the issue and treating it as a top priority. We’ll share updates as soon as we have more information.

Resolved

Our operations team has resolved the issue that was affecting some users' ability to log in and navigate the application. 

We sincerely apologize for the inconvenience this may have caused and appreciate your patience while we worked to fix it.