System Slowness

Incident

System Slowness

Status: closed
Start:
End:
Duration: 1 hour 18 minutes
Affected Components:
C3 Instance General Application Status - C3 Instance Login Feeds Emails API
Investigating

We are aware that some users are experiencing slowness when navigating through and using the application, particularly affecting the ability to delegate and select allocations. Our teams are prioritising this issue, and we will provide you with an update as soon as possible.

Resolved

We have resolved the slowness issues and the difficulties with delegating and selecting allocations that some users were experiencing. We apologize for any inconvenience this may have caused and appreciate your patience.