Site Latency

Incident

Site Latency

Status: closed
Start:
End:
Duration: 1 hour 31 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance EXPENSE - C5 Instance INVOICE - C5 Instance Login General Expense General Invoice Feeds Emails Emails Emails Image / Receipt Processing Image Processing API Exports Exports Pre-Approval Purchase Order Credit Cards
Update

Chrome River is aware of reported issues with application latency.  We are working to resolve these issues as our highest priority.  We will provide another update in 30 minutes, and apologize for the inconvenience this is causing.

Update

We are seeing improvements in system latency and are still working to improve the speeds. We will provide another update in 30 minutes. 

Resolved

Our Operations team has resolved the issues of latency and after monitoring, we are continuing to see this improved performance. We apologize for the inconvenience this may have caused.