Emails sent from Emburse Cards platform

Incident

Emails sent from Emburse Cards platform

Status: closed
Start:
End:
Duration: 1 day 2 hours 36 minutes
Affected Components:
C1 Instance C2 C3 Instance C5 Instance EXPENSE - C1 Instance EXPENSE - C2 EXPENSE - C3 Instance EXPENSE - C5 Instance Emails Emails Emails Emails
Update

We are currently experiencing a technical issue affecting the delivery of emails sent from the Emburse Cards platform. Our team is actively working to resolve the matter as their highest priority, and we expect to have it addressed shortly.

We apologize for any inconvenience this may cause and appreciate your patience as we work toward a resolution.

Resolved

Our Operations team has resolved an issue affecting the delivery of emails from the Emburse Cards platform. We apologize for the inconvenience.