Site Slowness

Incident

Site Slowness

Status: closed
Start:
End:
Duration: 2 hours 29 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance EXPENSE - C5 Instance INVOICE - C5 Instance Login General Expense General Invoice
Update

We are aware that some customers are experiencing general performance issues with the Chrome River application. Our operations team is treating this as a priority and is actively investigating the matter. We will provide further updates as more information becomes available. Thank you for your patience and understanding.

Resolved

The Chrome River Operations team has resolved the performance issues logging in and using the application. We thank you for your patience and apologize for any inconvenience.