Scheduled Maintenance on Saturday, July 27, 2024 22:00:00 UTC

Maintenance

Scheduled Maintenance on Saturday, July 27, 2024 22:00:00 UTC

Status: closed
Start:
End:
Duration: 4 hours
Affected Components:
C3 Instance General Application Status - C3 Instance Login
Update

On Saturday, July 27th, starting at 6:00 pm EDT/10:00 pm UTC, we will perform important system updates on the Production site. The system will be offline for up to 4 hours while we upgrade our infrastructure. The standard maintenance page will display for users during this period.

Resolved

The Chrome River scheduled maintenance has completed.