Delay in the Routing of Expense Reports

Incident

Delay in the Routing of Expense Reports

Status: closed
Start:
End:
Duration: 8 hours
Affected Components:
C5 Instance EXPENSE - C5 Instance General Expense
Update

Chrome River is aware of a delay in the routing of expense reports. We can confirm expense reports are routing, just slower than expected. We are working to resolve and will provide a further update once we know more. We apologize for the inconvenience.

Resolved

The backlog has fully cleared and all expense reports are routing as normal. We apologize for the delay.