Degraded performance

Incident

Degraded performance

Status: closed
Start:
End:
Duration: 2 hours 14 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance INVOICE - C5 Instance Login General Invoice Feeds Emails Emails Image Processing API Exports Purchase Order
Update

We are currently experiencing degraded performance, some users may notice slowness when using the application or trying to work with invoices.

Our engineering team is actively investigating the root cause and working to restore full performance.

We will provide an update as soon as more information becomes available.

We appreciate your patience and understanding.


Resolved

Our engineering team has successfully resolved the performance degradation issue.

We appreciate your patience and understanding as we worked to address and resolve this matter.