C3 degradation issues

Incident

C3 degradation issues

Status: closed
Start:
End:
Duration: 1 hour 51 minutes
Affected Components:
C3 Instance EXPENSE - C3 Instance General Expense
Update

Some users are experiencing degraded performance.

Users may notice slowness using the application or problems choosing allocations or delegating.


Our engineering team is actively investigating the root cause and working to restore full performance.

We will provide an update as soon as more information becomes available.

We appreciate your patience and understanding.


Update

Our Engineering team continues to work on resolving the performance issues. We’re making progress and will provide another update as soon as we have more information.

Thank you for your continued patience.

Resolved

Our engineering team has successfully resolved the slowness issues users where seeing in the application. They have also solved the problems users were seeing choosing allocations or delegating.


We appreciate your patience and understanding as we worked to address and resolve this matter.