Performance issues

Incident

Performance issues

Status: closed
Start:
End:
Duration: 39 minutes
Affected Components:
C5 Instance General Application Status - C5 Instance EXPENSE - C5 Instance Login General Expense Emails Image / Receipt Processing Exports Pre-Approval Credit Cards
Update

We are currently experiencing degraded performance affecting the Emburse Enterprise app.

Some users may notice slowness or inability to login, or review/create expense reports.


Our engineering team is actively investigating the root cause and working to restore full performance.

We will provide an update as soon as more information becomes available.

We appreciate your patience and understanding.


Resolved

Our engineering team has successfully resolved the issue and users should be able to login and create and review the expense reports.

We appreciate your patience and understanding as we worked to address and resolve this matter.