General System Slowness

Incident

General System Slowness

Status: closed
Start:
End:
Duration: 2 hours 30 minutes
Affected Components:
C3 Instance General Application Status - C3 Instance EXPENSE - C3 Instance INVOICE - C3 Instance ANALYTICS - C3 Instance Announcements C3 Instance Login General Expense General Invoice Feeds Emails Emails Emails Image / Receipt Processing Image Processing API Exports Exports Pre-Approval Purchase Order Credit Cards
Update

Our Operations team has been alerted to an issue causing latency and general system slowness for some users in the  c3 production environment.
Steps have already initiated to address the issue, with system performance already showing improvement. 

We will keep you updated here.

Our apologies for any inconvenience.


 

Resolved

Our Operations team has resolved an issue causing slowness while using the application.

We are continuing to monitor but we do not anticipate any further disruptions.

We apologize for an inconvenience this may have caused