Issues accessing the application

Incident

Issues accessing the application

Status: closed
Start:
End:
Duration: 1 hour 13 minutes
Affected Components:
C3 Instance General Application Status - C3 Instance Login
Update

We’re aware that some users are experiencing issues when trying to log in. Our team is actively working to resolve the problem as quickly as possible. We will provide another update within 15 minutes—or sooner, if available.

Update

We are actively investigating the login issues affecting some users. Our team is working diligently to resolve the problem as quickly as possible. We will share an update within the next 15 minutes, or sooner if new information becomes available.

Update

Our Operations and Engineering teams are actively working to resolve the login issues affecting some users. This remains their top priority. We will provide a further update once resovled. 

Resolved

The login issue affecting some users has been resolved. We apologize for the inconvenience this may have caused and appreciate your patience.