Adding Canadian Bank Accounts

Incident

Adding Canadian Bank Accounts

Status: closed
Start:
End:
Duration: 2 hours 56 minutes
Affected Components:
C1 Instance C3 Instance C5 Instance EXPENSE - C1 Instance EXPENSE - C3 Instance EXPENSE - C5 Instance General Expense General Expense General Expense
Update

We are currently aware of an issue preventing end users from adding a bank account in their account settings when Canadian Dollars is set as the target currency. This issue only affects customers who use Wise for end user reimbursements. Our engineering team is actively working with Wise to resolve the issue as quickly as possible.

Resolved

Our engineering team has resolved the issue that occurred when adding a new bank account in Account Settings with Canadian Dollars set as the target currency for Wise customers. We apologize for any inconvenience this may have caused.